Canada Immigration and Visa Discussion Forum Homepage
Forum Home Forum Home > Canada Immigration Topics > Family Class Sponsorship
  New Posts New Posts RSS Feed - Inland Application sent from Sept 2009 to Jan 2010
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Inland Application sent from Sept 2009 to Jan 2010

 Post Reply Post Reply Page  <1 414243
Author
Message
wordstar_28 View Drop Down
Junior Member
Junior Member


Joined: 29 Nov 2009
Location: toronto
Status: Offline
Points: 93
Post Options Post Options   Thanks (0) Thanks(0)   Quote wordstar_28 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jun 2011 at 7:35pm
Hi everyone! Its been a long time since the last time I logged in. Surprised that the sept 2009 thread is still here! I am also stocked like you vincywife. Mistakenly our visa office way back home sent the application kit of my dependent child to the wrong address. And they didn't inform me about it. I called them sept last year and they told me they sent it march 2010 (application kit), what a waste of time! But I can't do anything so I just asked them to send another kit to my dependent child. They received it on oct 2010, and all goes to the right order. I waited patiently... But I know waiting can gives a lot of stress. I thanked God so much coz my application is almost to end. I'm scheduled for landing interview on July 13, 2011. So just be patient! Enjoy the summer! Don't worry everything will be alright! You already have OWP, so I believed there's no problem at all! Just wait! God bless!

Sept 22, 2009 application sent
Sept 25, 2009 application received
Oct 30, 2009 application process started
April 29, 2010 Ist stage approval+OWP
May 2010-may 2011 wait... wait... wait...
may 23, 2011 received letter from cic (application completed/approved)
june 9, 2011 received letter from local office for landing interview
Back to Top
rdanny View Drop Down
Junior Member
Junior Member


Joined: 18 Mar 2010
Location: Alberta
Status: Offline
Points: 56
Post Options Post Options   Thanks (0) Thanks(0)   Quote rdanny Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jan 2012 at 9:41pm
So after landing in Oct 2010 I received a letter about 4 months later asking me to resubmit photos as they lost the ones I left them with during my landing interview. I resubmitted and another 4 months later I received another letter advising me that the photos I submitted didn't meet their standards. I'd like to point out that all of the photos I sent in were taken and printed by 'professional' photographers.

In the summer of 2011 I had to leave the country so I went to the consulate general abroad and got a temp. PR card, which was good for one entry. My passport has since expired and I can't renew my passport without a valid PR card.

I received another letter, this time sent to an incorrect house # (therefore delayed by over a month). I went to a different photographer again and re-submitted my photos to the field office in Calgary. That was one month ago and I still have not heard anything.

It's rather frustrating that I still don't have my initial PR card after 15 months!

Any input or advice? Has anyone else experienced something similar?
Citizenship
Sent application 05-21-13
Re-sent w/ missing info 07-17-13
App received 07-22-13
Started processing 10-02-13
Received book 10-29-13
Received RQ - 02-24-14
Back to Top
 Post Reply Post Reply Page  <1 414243
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.156 seconds.